Недопустимая ссылка в эксель как убрать
Перейти к содержимому

Недопустимая ссылка в эксель как убрать

  • автор:

Ошибка сводной таблицы Excel «Недопустимая ссылка на источник данных»

При открытии книги Excel, содержащей квадратные скобки, в имени (например, «foo [1]») при попытке создания сводных таблиц с использованием данных из книги пользователь получит следующее сообщение об ошибке:ссылка на источник данных недействительна

Причина

Причина из-за того, что квадратные скобки являются недопустимыми символами в имени файла книги Excel.

Решение

Это поведение ожидается, если выполняются эти условия. Для решения этой проблемы пользователю потребуется удалить все недопустимые символы Excel из имени файла.

Дополнительная информация

Эта проблема может возблюдаться при попытке открыть книгу Excel из Internet Explorer. Internet Explorer создает копию файла во временной папке, переименование файла с помощью квадратных скобок. Это можно избежать, если нажать кнопку «Сохранить», а не «Открыть», когда Internet Explorer выведет файл пользователю.

Как исправить #REF! ошибка

Excel для Microsoft 365 Excel для Microsoft 365 для Mac Excel для Интернета Excel 2021 Excel 2021 для Mac Excel 2019 Excel 2019 для Mac Excel 2016 Excel для iPad Excel для iPhone Excel для планшетов с Android Excel для телефонов с Android Excel для Windows Phone 10 Excel Mobile Еще. Меньше

Ошибка #REF! отображается, когда формула ссылается на недопустимую ячейку. Чаще всего это происходит потому, что формула ссылается на ячейки, которые были удалены или заменены другими данными.

#ССЫЛКА! из-за удаления столбца

В следующем примере в столбце E используется формула =СУММ(B2;C2;D2).

Формула с явными ссылками на ячейки, например =SUM(B2,C2,D2), может вызвать #REF! ошибка при удалении столбца.

Удаление столбцов B, C или D приведет к #REF! ошибку #ЗНАЧ!. В этом случае мы удалим столбец C (Продажи 2007), а формула теперь будет читать =СУММ(B2,#REF!,C2). Если вы используете явные ссылки на ячейки, как это (когда вы ссылаетесь на каждую ячейку по отдельности, разделенные запятой) и удаляете строку или столбец, на которые ссылается ссылка, Excel не может разрешить их, поэтому он возвращает #REF! ошибку #ЗНАЧ!. Это основная причина, по которой не рекомендуется использовать явные ссылки на ячейки в функциях.

Пример ошибки #ССЫЛКА! из-за удаления столбца.

  • Если вы случайно удалили строки или столбцы, можно сразу же нажать кнопку Отменить на панели быстрого доступа (или нажать клавиши CTRL+Z), чтобы восстановить их.
  • Измените формулу так, чтобы она ссылалась на диапазон, а не на отдельные ячейки, например =СУММ(B2:D2). Теперь можно удалить любой столбец в диапазоне суммирования, и Excel автоматически скорректирует формулу. Чтобы вычислить сумму значений в строках, также можно использовать формулу =СУММ(B2:B5).

Пример функции ВПР с неправильными ссылками на диапазоны

В следующем примере =VLOOKUP(A8;A2:D5;5;FALSE) вернет #REF! ошибка, так как она ищет значение, возвращаемое из столбца 5, но диапазон ссылок — A:D, то есть только 4 столбца.

Пример формулы ВПР с неправильным диапазоном. Формула =VLOOKU(A8;A2:D5;5;FALSE). В диапазоне ВПР нет пятого столбца, поэтому значение 5 вызывает #REF! ошибку #ЗНАЧ!.

Измените диапазон, чтобы он был больше, или уменьшите значение подстановки столбца в соответствии с диапазоном ссылок. Формулы =ВПР(A8;A2:E5;5;ЛОЖЬ) будет работать правильно, так же как и формула =ВПР(A8;A2:D5;4;ЛОЖЬ).

INDEX с неправильной ссылкой на строку или столбец

В этом примере формула =INDEX(B2:E5,5;5) возвращает #REF! ошибка, так как диапазон INDEX состоит из 4 строк на 4 столбца, но формула запрашивает возвращать значения в 5-й и 5-й строках.

Пример формулы ИНДЕКС с недопустимой ссылкой на диапазон. Формула имеет вид =ИНДЕКС(B2:E5;5;5), но диапазон содержит всего 4 строки и 4 столбца.

Измените ссылки на строки и столбцы так, чтобы они попадали в диапазон поиска функции ИНДЕКС. Формула =ИНДЕКС(B2:E5;4;4) вернет правильный результат.

Ссылка на закрытую книгу с помощью INDIRECT

В следующем примере функция INDIRECT пытается ссылаться на закрытую книгу, вызывая #REF! ошибку #ЗНАЧ!.

Пример ошибки #ССЫЛКА! из-за использования функции ДВССЫЛ для ссылки на закрытую книгу.

Откройте книгу, на который ссылается ссылка. Эта же ошибка возникает при ссылке на закрытую книгу с динамической функцией массива.

Структурированные ссылки не поддерживаются

Структурированные ссылки на имена таблиц и столбцов в связанных книгах не поддерживаются.

Вычисляемые ссылки не поддерживаются

Вычисляемые ссылки на связанные книги не поддерживаются.

Ошибка недопустимой ссылки на ячейку

Перемещение или удаление ячеек вызвало недопустимую ссылку на ячейку, или функция возвращает ошибку ссылки.

Проблемы с OLE

Если вы использовали ссылку OLE, которая возвращает #REF! ошибка, а затем запустите программу, которую вызывает ссылка.

Примечание. OLE — это технология, которая используется для обмена информацией между приложениями.

Проблемы С DDE

Если вы использовали раздел динамического обмена данными (DDE), возвращающий #REF! Ошибка, сначала проверка, чтобы убедиться, что вы ссылаетесь на правильный раздел. Если вы по-прежнему получаете #REF! ошибка, проверка параметры центра управления безопасностью для внешнего содержимого, как описано в разделе Блокировать или разблокировать внешнее содержимое в документах Microsoft 365.

Примечание. Динамический обмен данными (DDE)— это установленный протокол для обмена данными между программами на базе Microsoft Windows.

Проблемы с макросами

Если макрос вводит на листе функцию, которая ссылается на ячейку над функцией, а ячейка, содержащая функцию, находится в строке 1, функция вернет #REF! поскольку нет ячеек над строкой 1. Проверьте функцию, чтобы узнать, ссылается ли аргумент на ячейку или диапазон ячеек, которые недопустимы. Для этого может потребоваться изменить макрос в Редактор Visual Basic (VBE), чтобы учесть эту ситуацию.

Дополнительные сведения

Вы всегда можете задать вопрос эксперту в Excel Tech Community или получить поддержку в сообществах.

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа «А какой критерий?», «А куда выводить результат?», «А сколько строк?» и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

  • Профессиональные приемы работы в Microsoft Excel
  • ► Обмен опытом
  • ► Microsoft Excel
  • ► Недопустимые ссылки:как найти и устранить ошибку

Неверная ссылка на рисунок в эксель, как удалить?

Проблема в следующем — проделал немалую работу в эксель (формулы, ссылки, условия) короче терять прогресс не хочется, и отвлекся на другу задачу, короче после этого скопировал в ячейку ссылку на рисунок хрен знает где на компьютере, вставился объект, строку формул я очистил но теперь я не могу переключиться на другую ячейку, постоянно пишет неверная ссылка, выделить объект невозможно, сохранить документ также не могу, помогите, как удалить этот объект, либо прописать уже ссылку на что либо чтобы формулу закрыть

Дополнен 8 лет назад

Не могу выкинуть сохраненный файл, потому как он НЕ СОХРАНЯЕТСЯ БЛИН

Лучший ответ

в студию что там у вас..
ссылка в где, в ячейке или где?
вставка-гиперссылка
или правой по ячейке-удалить гиперссылку
esc нажать самый простой вариант или назад если возможно.
или удалить

Юра ЯхницаМастер (1723) 8 лет назад

Все гениальное просто, спасибо за совет, esc помог, мин 20 блин бился, искал что туда прописать чтобы эта сволочь закрылась

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *