Кумир лесенка алгоритм как сделать
Перейти к содержимому

Кумир лесенка алгоритм как сделать

  • автор:

Исполнитель Робот. Решение задач.

Нажмите, чтобы узнать подробности

В данной разработке разбираются задчи для исполнителя Робот, которые вызывают затруднения у многих школьников — это задачи с различными лесенками.

Просмотр содержимого документа
«Исполнитель Робот. Решение задач.»

использовать Робот
алг
нач
. нц пока снизу стена и справа свободно
. . вправо
. кц
. нц пока справа стена
. . вверх
. . нц 3 раз
. . . вправо
. . . закрасить
. . кц
. кц
кон

использовать Робот
алг
нач
. | Поднимаемся вверх по первой лестнице до верхней площадки и красим клетки
. нц пока справа стена
. . закрасить
. . вверх
. . закрасить
. . вправо
. кц
. | Закрашиваем клетку на верхней площадке
. закрасить
. вправо
. | Проверяем условие, что лестница еще не закончилась, спускаемся по ней
. | и красим клетки
. нц пока снизу свободно
. . закрасить
. . вниз
. . закрасить
. . вправо
. кц
кон

Исходное поле Робота:

Сначала идет горизонтальная стена, ее длина неизвестна. Далее идет лесенка вниз, высота ступеньки – 1 клетка, длина ступеньки – 2 клетки. Количество ступенек неизвестно. Далее идет лесенка вверх, высота ступеньки – 1 клетка, длина ступеньки – 2 клетки. Количество ступенек неизвестно. Необходимо закрасить клетки над ступеньками обоих лесенок. Как показано на 2 рисунке.

использовать Робот
алг
нач
. | Двигаемся вдоль нижней стены до начала лесенки
. нц пока снизу стена
. . вправо
. кц
. вниз
. |Спускаемся вниз по первой лестнице до нижней площадки и красим клетки
. нц пока слева стена
. . закрасить
. . вправо
. . закрасить
. . если справа свободно
. . . то вправо
. . все
. . если снизу свободно
. . . то вниз
. . все
. кц
. | Поднимаемся по второй лесенке и красим клетки
. нц пока справа стена
. . вверх
. . вправо
. . закрасить
. . вправо
. . закрасить
. кц
кон

Информатика. Нужно составить алгоритм. Программа «Кумир»

На бесконечном поле имеется лестница. Сначала лестница спускается вниз, потом под-нимается вверх. После подъема лестница пере-ходит в вертикальную стену. Высота каждой ступени — 1 клетка, ширина — 1 клетка. Коли-чество ступенек, ведущих вверх, и количество ступенек, ведущих вниз, неизвестно. Между спуском и подъемом ширина площадки — 1 клетка. Робот находится в клетке, расположен-ной в начале спуска. Напишите для Робота алго-ритм, закрашивающий все клетки, расположен-ные непосредственно над лестницей, как показа-но на рисунке. Конечное расположение Робота может быть произвольным.

Голосование за лучший ответ

Программисты у нас там → https://otvet.mail.ru/programming/

Евгения КураковаПрофи (682) 6 лет назад

нужно решение а) г) д)

ᛟᏔҨŁ₣ᛟ Искусственный Интеллект (281200) Программисты у нас там → https://otvet.mail.ru/programming/

Похожие вопросы

Практическая работа по информатике. Исполнитель Робот

Практическая работа по информатике. Исполнитель Робот

Часто на уроках и в задании 20.1 ОГЭ по информатике требуется исполнителем «Робот» спускаться или подниматься по лестнице. Надо понимать, что спуск или подъем по лестнице осуществляется одним циклом. Как правило, чтобы проверить работоспособность алгоритма необходимо добавлять ступени на лестнице. Алгоритм должен выполнятся независимо от количества ступеней, например, как для двух ступеней, так и для двадцати.

ЗАДАЧА

На бесконечном поле имеется горизонтальная стена, бесконечно продолжается влево и заканчивается лестницей, которая спускается слева направо. Высота каждой ступени — две клетки, ширина — две клетки. Робот находится на горизонтальной стене для спуска по лестнице. На рисунке указан один из способов расположения лестницы и Робота( Робот обозначен символом ).

Исполнитель Робот лестница

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные на ступенях лестницы. Требуется закрасить только клетки, удовлетворяющие данному условию.

Например, для приведенного выше рисунка Робот должен закрасить клетки:

исполнитель робот лестница результат конечный результат

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого количества ступеней. При исполнении алгоритма Робот не должен разрушиться.

РЕШЕНИЕ

Данную задачу будем решать в среде программирования КуМир. Откроем программу и перейдем в меню Робот — > Редактировать обстановку

исполнитель робот редактировать обстановку

Строим лестницу. тЛевой кнопкой мыши щелкаем по стенкам клетки. Ромб (робот) перемещаем в нужное место, зажав левую кнопку мыши

Исполнитель Робот лестница

Выходим из режима редактирования меню Робот — > Редактировать обстановку. Далее напишем на первой строчке команду «использовать Робот».

исполнитель робот команда использовать робот

Сначала вспомним некоторые команды для исполнителя Робот.

№ п/п Команда Обозначение
1 нц начало цикла
2 кц конец цикла
3 закрасить закрашиваетcя клетка
4 вверх, вниз, влево, вправо движение робота
5 нач, кон начало и конец программы

В задании сказано, что

Алгоритм должен решать задачу для произвольного размера поля и любого количества ступеней

Это означает, что Робот должен передвигаться с помощью цикла «Пока». Рассуждаем так: снизу под роботом стена, значит снизу не свободно. На 4 строчке редактора пишем команду

Внутри цикла необходимо последовательно выполнить команды:

вправо вниз закрасить вправо закрасить влево вниз закрасить вправо закрасить

Пути движения робота

Полностью готовая программа выглядит так:

использовать Робот алг нач нц пока снизу не свободно вправо вниз закрасить вправо закрасить влево вниз закрасить вправо закрасить кц кон

Для проверки алгоритма добавим ещё несколько ступеней и проверим результат

Исполнитель Робот итоговый результат

Итак, алгоритм закрашивает клетки при любом количестве ступеней лестницы.

0 75 139 просмотров

Вам также может быть интересно

Практическая работа по информатике. Среда программирования КуМир. Решение математической задачи

Практические работы 0 5 147 просмотров

Среда программирования КуМир Решение математической задачи Поезд, двигаясь равномерно со скоростью 93 км/ч, проезжает

Расчёт заработной платы сотрудников кафе

Практические работы 0 4 963 просмотров

Электронные таблицы в Microsoft Excel Расчёт заработной платы сотрудников кафе Данную практическую работу можно

ЕГЭ 2019 по информатике задание 22

ЕГЭ 0 22 568 просмотров

ЕГЭ 2019 по информатике задание 22 Тема: «Динамическое программирование» Исполнитель Вычислитель преобразует число, записанное

Задания для программы кумир робот. Практические задания для исполнителя робот

Ее для дальнейшей работы и научились задавать . Теперь перейдем непосредственно к составлению алгоритмов для Робота с использованием простых команд.

Если вам больше нравится информация в формате видеоуроков, то на сайте есть видеоурок

У любого исполнителя должна быть система команд (СКИсистема команд исполнителя ). Система команд исполнителя — совокупность всех команд, которые может выполнить исполнитель. В качестве примера рассмотрим дрессированную собаку. Она умеет выполнять некоторые команды — «Сидеть», «Лежать», «Рядом» и т. п. Это и есть ее система команд.

Простые команды Робота

У нашего Робота тоже есть система команд. Сегодня мы рассмотрим простые команды Робота . Всего их 5:

Результат выполнения этих команд понятен из их названия:

  1. вверх — переместить Робота на одну клетку вверх
  2. вниз — переместить Робота на одну клетку вниз
  3. влево — переместить Робота на одну клетку влево
  4. вправо — переместить Робота на одну клетку вправо
  5. закрасить — закрасить текущую клетку (клетку в которой находится Робот).

Эти команды можно писать с клавиатуры, а можно использовать горячие клавиши (нажав их команды будут вставляться автоматически):

  • вверх — Escape, Up (стрелка вверх)
  • вниз — Escape, Down (стрелка вниз)
  • влево — Escape, Left (стрелка влево)
  • вправо — Escape, Right (стрелка вправо)
  • закрасить — Escape, Space (пробел)

Обратите внимание, что набирать нужную комбинацию горячих клавиш нужно не привычным нам способом! Мы привыкли нажимать клавиши одновременно, а здесь их нужно нажимать последовательно . К примеру, чтобы ввести команду вверх, нужно нажать Escape, отпустить ее и после этого нажать стрелку вверх. Это нужно помнить.

Теперь мы готовы написать первый алгоритм для Робота. Предлагаю начать с простого — нарисуем квадрат со стороной 3 клетки. Поехали!

Запускаем Кумир, его. Можно начинать писать программу? Конечно нет! Мы же не ! Делаем это. Предлагаю использовать вот такую:

Вот теперь все готово. Начинаем писать программу. Пока она выглядит так

Удаляем символ «|» и называем наш алгоритм «Квадрат»

Предлагаю рисовать квадрат, двигаясь по часовой стрелке. Для начала закрасим текущую клетку, дав команду закрасить . Потом делаем шаг вправо и опять закрашиваем клетку. И еще раз шаг вправо и закрасить.

Попробуем запустить программу и посмотреть что же получилось. Для запуска нажимаем F9 или же кнопку на панели инструментов

В результате мы должны увидеть вот такую картину

Если такое окно Робота у вас не появилось, то на панели инструментов щелкните «Показать окно Робота » или в меню Робот выберите пункт «Показать окно Робота «. Продолжаем дальше.

Теперь мы будем двигаться вниз и закрашивать правую сторону квадрата:

Потом пойдем влево, закрашивая нижнюю границу квадрата

У нас осталась одна незакрашенная клетка. Закрасим ее

Все готово! В итоге наша программа выглядит так:

использовать Робот

алг Квадрат

Знакомство с программой Кумир осваение азов программирования.

В ней учащиеся могут получить практические навыки при создании и отладке алгоритма, работая с такими исполнителями, как Робот, Чертёжник, Водолей, Кузнечик,Черепашка.

При изучении одного из наиболее трудных разделов информатики «алгоритмизация и программирование».

Цель разработки :

Скачать:

Предварительный просмотр:

Методическая разработка по информатике.

Тема: «Исполнитель Робот в программе КуМир на уроках информатики »

учитель технологии «Информатика и ИКТ»

Цель разработки : изучить возможности программирования на примере конкретного исполнителя Робот с использованием среды КУМИР; дать практические навыки работы с исполнителем.

Методическая разработка составлена для проведения уроков информатики Практика на компьютере : работа с учебным исполнителем алгоритмов; составление линейных, ветвящихся и циклических алгоритмов управления исполнителем; составление алгоритмов со сложной структурой; использование вспомогательных алгоритмов (процедур, подпрограмм).

Учащиеся должны знать:

  • что такое исполнитель; СКИ Робота, среду исполнителя Робот;
  • что такое алгоритм; в чем состоят основные свойства алгоритма;
  • способы записи алгоритмов: блок-схемы, учебный алгоритмический язык; основные алгоритмические конструкции: следование, ветвление, цикл; структуры
  • алгоритмов; ⇒ назначение вспомогательных алгоритмов; технологии построения сложных алгоритмов:

Учащиеся должны уметь:

  • понимать описания алгоритмов на учебном алгоритмическом языке;
  • выполнить трассировку алгоритма для известного исполнителя;
  • составлять линейные, ветвящиеся и циклические алгоритмы управления исполнителя Робот; выделять подзадачи; определять и использовать вспомогательные алгоритмы.

Занятие 1 (2 часа) Урок 1.

Исполнитель Робот. Система команд исполнителя.

  1. Описание СКИ исполнителя, среды исполнителя.

2.Разбор типичных алгоритмов Робота.

Рассмотрим описание исполнителя.

Среда исполнителя : Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки.

СКИ Робота : простые команды: вверх, вниз, влево, вправо, закрасить.

Команды логические: (проверки условия)

сверху свободно снизу свободно

слева свободно справа свободно.

Логические связки: И,НЕ, ИЛИ:

Пример:(Не слева свободно) или (не справа свободно)

Команда ветвления : команда цикла:

Если условие то нц пока условие

Серия команд серия команд

(В КИМах 2009 года команды Робота отличались от привычных детям, что приводило к путанице 🙂

Команда ветвления : команда цикла:

Если условие то нц пока условие делать

Серия команд серия команд

Общий вид окна программы Кумир. Графическая среда Робота:

В КИМах демонстрационного варианта 2010 года формат команд изменен на привычный

Порядок создания алгоритма:

1.Командами Инструменты -Редактировать стартовую обстановку нарисовать на поле Робота стены и установить Робота в начальное положение.

2.Командами Робот- Сменить стартовую обстановку сохранить новую обстановку.

3.Командами Вставка- Использовать Робот указать исполнителя.

4.В окне документа записать алгоритм, используя меню Вставка.

5.Командами Выполнение –выполнить непрерывно (или по шагам) запустить алгоритм.

6.Рассмотреть результат выполнения алгоритма и при необходимости произвести его отладку.

Занятие 1 (2 часа) Урок 2.

Практическая работа « Составление линейных алгоритмов».

Задания: 1.Робот в произвольной точке поля. Закрасить клетку сверху, снизу и справа от исходного положения.

  1. Робот в произвольной точке поля. Передвинуть Робот на 4 клетки вправо, закрасив их.
  2. Создайте новую стартовую обстановку, нарисовав на поле квадрат со стороной 4 клетки. Сохраните обстановку как стартовую.
  3. Создайте новую стартовую обстановку, нарисовав на поле коридор с проходами в стенах. Сохраните обстановку как obst2.fil. Смените стартовую обстановку на вновь созданную.

Занятие 2 (2 часа) Урок 1.

Тема : Ветвление и последовательная детализация алгоритма.

Разбор задач КИМов с использованием исполнителя Робот.

если не снизу свободно

если не снизу свободно

если не снизу свободно

если не снизу свободно

если не снизу свободно

если не снизу свободно

Пр. раб. №14. Составление и отладка алгоритмов ветвления

Задания. См. Приложение.

Занятие 3. Циклические алгоритмы. Урок 1-2

Цель: раскрыть сущность понятия цикла в алгоритмах, показать формы записи циклов алгоритмах, дать навыки создания и записи циклических алгоритмов.

Пр. раб. №15. Составление и отладка циклических алгоритмов

1.Составьте алгоритм, закрашивающий все внутренние клетки, прилегающие к стене.

нц пока справа свободно

нц пока снизу свободно

нц пока не снизу свободно

2.Составить алгоритм, закрашивающий все клетки между Роботом и стеной. Расстояние до стены неизвестно.

нц пока справа свободно

3.Составить алгоритм, закрашивающий все клетки, находящиеся между двумя стенами.

нц пока (не сверху свободно) или (не снизу свободно)

если (не сверху свободно) и (не снизу свободно)

4.Составить алгоритм, закрашивающий все клетки вокруг прямоугольной стены.

нц пока не справа свободно

нц пока не снизу свободно

нц пока не слева свободно

нц пока не сверху свободно

нц пока не снизу свободно

нц пока слева свободно

нц пока не слева свободно

нц пока сверху свободно

нц пока не сверху свободно

Занятие 4 Урок 1

Цель: ввести понятие основного и вспомогательного алгоритма; объяснить правила использования вспомогательного алгоритма; разобрать примеры алгоритмов с использованием вспомогательного.

1.Ввод новых терминов (основного и вспомогательного алгоритма, вызова) и объяснение новых понятий.

2.Разбор примеров решения задач с применением вспомогательного алгоритма.

При решении некоторых задач удобно разбить их на более мелкие подзадачи, каждую из которых можно оформит как самостоятельный алгоритм. В этом случае сначала составляется так называемый основной алгоритм, в котором для решения подзадач используются вызовы вспомогательных алгоритмов, которые дописываются позднее. Такой способ решения называется методом последовательного уточнения. Он позволяет работать над проектом группе программистов, каждый при этом решает свою подзадачу.

В процессе решения задачи каждый вспомогательный алгоритм может при необходимости быть разбит на более мелкие вспомогательные алгоритмы.

Команда выполнения вспомогательного алгоритма называется вызовом и записывается в теле основного алгоритма.

Один и тот же алгоритм может рассматриваться как основной и вспомогательный по отношению к другим алгоритмам. В алгоритмическом языке сначала записывается основной алгоритм, ниже подряд записываются вспомогательные.

Робот находится в верхнем левом углу поля. Стен и закрашенных клеток нет. Составить алгоритм, с использованием вспомогательного, рисующий четыре крестика на одной горизонтали. Конечное положение Робота может быть произвольным.

Разбор на доске:

Задача2. Робот находится в верхнем левом углу поля. Стен и закрашенных клеток нет. Составьте алгоритм, который закрашивает в шахматном порядке квадрат 8 х 8. Конечное положение Робота может быть произвольным.

Занятие 4 Урок 2

Практическая работа на ПК «Решение задачи с использованием вспомогательных алгоритмов» .

Цель : привить практические навыки построения алгоритмов методом последовательного уточнения.

1.Задание полностью проходит за ПК. Учащиеся получают задания и выполняют их в программной среде Кумир. Результаты Работы сохраняются в виде файлов для последующей проверки.

Задача1 . Робот находится в нижнем левом углу поля. Стен и закрашенных клеток нет. Составьте алгоритм, который закрашивает 6 вертикальных полос одинаковой длины в 6 клеток. Конечное положение Робота может быть произвольным.

Задача2 .Используя вспомогательные, составьте алгоритм для закрашивания клеток, образующих число 1212.

Домашнее задание : Придумайте алгоритм, рисующий следующее изображение: Для решения задачи примените два вспомогательных алгоритма.

Занятие 5 Урок 1-2

«Составление алгоритма в среде исполнителя Робот».

Цель: проверить полученные знания по созданию и умению анализировать алгоритмы в программной среде Кумир.

Задания для контрольной работы делятся по уровням сложности и включает в себя 3 задачи с исполнителем Робот (1 и 2 задача –на ветвление и циклы, 3 задача с- на использование вспомогательного алгоритма.) Тексты заданий приводятся в приложении.

Исходные и конечные обстановки и созданные алгоритмы записываются в виде файла.

Оценка выставляется соответственно уровню сложности задания. Ученик вправе сам выбрать тип задания.

Разделы: Информатика

  • Расширить представления учащихся об исполнителях алгоритмов;
  • закрепить представление об алгоритме как модели деятельности исполнителя.
  • сформировать умение записи, исполнения и отладки алгоритмов с использованием команд робота в среде “Кумир”
  • система Кумир;
  • мультимедийный проектор;
  • карточки-задания;
  • компьютеры.

1. Организационный момент.

2. Проверка усвоения изученного материала.

  1. Блиц-опрос учащихся на знание основных характеристик исполнителя чертежник: круг решаемых задач, среда исполнителя, система команд исполнителя, система отказов исполнителя, режимы работы исполнителя.
  2. Обсуждение № 17 из д/з
  3. Визуальная проверка № 18-19 из д/з.

3. Объяснение нового материала.

Исполнитель Робот действует на прямоугольном клетчатом поле. Между некоторыми клетками поля могут быть расположены стены. Некоторые клетки могут быть закрашены.

Робот занимает ровно одну клетку поля. По командам вверх, вниз, влево и вправо Робот перемещается в соседнюю клетку в указанном направлении. Если на пути оказывается стена, то происходит отказ – выдается сообщение о невозможности выполнить очередную команду.

По команде закрасить Робот закрашивает клетку в которой стоит. Если клетка уже была закрашена, то она закрасится повторно, хотя никаких видимых изменений не произойдет.

Важно помнить, что Робот может исполнять только правильно записанные команды. Например, если вместо команды вниз написать внис , то Робот эту запись не поймет и сразу же сообщит об ошибке.

Вопрос: Вспомните, как называются ошибки в записи команд. (Синтаксические и логические.)

Напишем программу, исполняя которую Робот нарисует на клетчатом поле меандр из четырех витков.

нач
. нц 4 раз
. . вправо
. . закрасить
. . влево
. . закрасить
. . влево
. . закрасить
. . вверх
. . закрасить
. . вверх
. . закрасить
. . вправо
. . закрасить
. . вправо
. . вправо
. . вправо
. . вниз
. . вниз
. кц
.
кон

Исполнитель Робот может принять любую стартовую обстановку. Инструменты → Редактировать стартовую обстановку Робота. В окошке строим стартовую обстановку и сохраняем как стартовую под любым именем.

  1. Выполните тот же рисунок с помощью вспомогательного алгоритма.
  2. Предложите свой вариант программы.

использовать Робот
алг
нач
. меандр
. меандр
. меандр
кон

Алг меандр
нач
. вправо
. закрасить
. влево
. закрасить
. влево
. закрасить
. вверх
. закрасить
. вверх
. закрасить
. вправо
. закрасить
. вправо
. вправо
. вправо
. вниз
. вниз
кон

Домашнее задание.

§ 3.1, 3.2 (1, 2) РТ № 1, 2, 7, 11 (стр. 85) Босова Л. Информатика 7 кл.

Программа Кумир

Кто такой исполнитель Робот?

  • Представьте себе клетчатое поле (как лист из тетради в клеточку) на котором находится некий объект, который мы назовем Робот. Используя специальные команды, мы можем этим Роботом управлять — перемещать его по клеткам, закрашивать клетки. И в большинстве случаев наша задача будет заключаться в том, чтобы написать такую программу для Робота, выполняя которую он будет закрашивать определенные клетки.

Настройка среды Кумир для исполнителя Робот

  • Запущенная программа Кумир выглядит так.

Стартовая обстановка Робота

  • Перед началом выполнения программы необходимо задать исполнителю Робот стартовую обстановку. Это значит установить Робота в нужную позицию, расставить стены, закрасить нужные клетки и т. п. Этот шаг очень важен. Если его проигнорировать, то программа может работать неправильно или вообще завершится аварийно.

Нажмите на Редактировать обстановку


Исполнитель Робот. Простые команды.

Результат выполнения этих команд понятен из их названия:

  • вверх — переместить Робота на одну клетку вверх
  • вниз — переместить Робота на одну клетку вниз
  • влево — переместить Робота на одну клетку влево
  • вправо — переместить Робота на одну клетку вправо
  • закрасить — закрасить текущую клетку (клетку в которой находится Робот).

Пример алгоритма

  • Сначала необходимо написать фразу:
  • использоватьРобот

Если известно сколько клеток нужно закрасить, то алгоритм решения будет следующим!

  • Напишите программу для решения следующей задачи, если известно сколько клеток нужно закрасить

  • 1. Цикл со счетчиком применяется когда заранее известно сколько повторений необходимо сделать.

нц раз

Здесь мы должны указать количество повторений (число) и команды, которые будут повторяться. Команды, которые повторяются в цикле называют телом цикла.


  • Напишите программу для решения следующей задачи, используя цикл со счетчиком

  • 2. Цикл с условием- пока условие истинно-цикл выполняется, если ложно-то не выполняется
  • У исполнителя Робот есть несколько условий

сверху свободно

снизу свободно

слева свободно

справа свободно

сверху стена

снизу стена

слева стена

справа стена

  • Можно использовать частицы: НЕ, И, ИЛИ

Структура цикла с условием

нц пока справа свободно


  • Напишите программу для решения следующей задачи, используя цикл с условием:

  • Напишите программу для решения следующей задачи, используя циклы с условием:



  • 2. Робота надо перевести из стартового положения в конечное, закрашивая стенки


  • На бесконечном поле имеется горизонтальная стена. Длина стены неизвестна. Робот находится сверху от стены в левом ее конце. На рисунке приведено расположение робота относительно стены (робот обозначен буквой «Р»):

Ответ на задание №5

  • нц пока не (снизу свободно)

Начало цикла (нц) и условие (пока не(снизу свободно)) — пишутся на одной строчке.


Конструкция если

  • сверху свободно снизу свободно слева свободно справа свободно
  • Эти команды можно использовать вместе с условием «если» , имеющим следующий вид:
  • еслиусловието
  • последовательность команд
  • Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:
  • если справа свободно то
  • вправо
  • закрасить

Длины стен неизвестны.

Ответ на задание №7

пока не свер­ху сво­бод­но

пока свер­ху сво­бод­но

пока спра­ва сво­бод­но

пока не спра­ва сво­бод­но

пока спра­ва сво­бод­но

пока не спра­ва сво­бод­но

Длины стен неизвестны.

В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны.

Ответ на задание №8

пока свер­ху сво­бод­но

пока не свер­ху сво­бод­но

пока свер­ху сво­бод­но

пока не свер­ху сво­бод­но

пока не снизу сво­бод­но

пока снизу сво­бод­но

пока не снизу сво­бод­но

Длины стен неизвестны.

В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны.

Ответ на задание №9

пока снизу сво­бод­но

пока не снизу сво­бод­но

пока снизу сво­бод­но

пока не снизу сво­бод­но

пока не свер­ху сво­бод­но

пока свер­ху сво­бод­но

пока не свер­ху сво­бод­но

Длины стен неизвестны.

В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны.

Ответ на задание №10

пока с­ле­ва сво­бод­но

пока не слева сво­бод­но

пока слева сво­бод­но

пока не с­ле­ва сво­бод­но

пока не спра­ва сво­бод­но

пока спра­ва сво­бод­но

пока не спра­ва сво­бод­но

Длины стен неизвестны.

В каждой стене есть ровно один проход, точное место прохода и его ширина неизвестны.

Ответ на задание №11

пока не свер­ху сво­бод­но

пока не свер­ху сво­бод­но

пока снизу сво­бод­но

пока не свер­ху сво­бод­но

На бес­ко­неч­ном поле име­ет­ся лест­ни­ца. Сна­ча­ла лест­ни­ца спус­ка­ет­ся вниз спра­ва на­ле­во, затем спус­ка­ет­ся вниз слева на­пра­во. Вы­со­та каж­дой сту­пе­ни — одна клет­ка, ши­ри­на — две клет­ки. Робот на­хо­дит­ся спра­ва от верх­ней сту­пе­ни лест­ни­цы. Ко­ли­че­ство сту­пе­нек, ве­ду­щих влево, и ко­ли­че­ство сту­пе­нек, ве­ду­щих впра­во, не­из­вест­но. На ри­сун­ке ука­зан один из воз­мож­ных спо­со­бов рас­по­ло­же­ния лест­ни­цы и Ро­бо­та (Робот обо­зна­чен бук­вой «Р»).

Ответ на задание №12

Дви­га­ем­ся вниз под лест­ни­цей спра­ва на­ле­во, пока не дой­дем до стыка лест­ниц:

нц пока снизу сво­бод­но

Дви­га­ем­ся вниз до конца спус­ка­ю­щей­ся лест­ни­цы, за­кра­ши­вая нуж­ные клет­ки на пути:

нц пока не слева сво­бод­но


Ответ на задание №13

нц пока слева сво­бод­но

нц пока не слева сво­бод­но

На бес­ко­неч­ном поле име­ет­ся пря­мо­уголь­ник, огра­ни­чен­ный сте­на­ми. Длины сто­рон пря­мо­уголь­ни­ка не­из­вест­ны. Робот на­хо­дит­ся внут­ри пря­мо­уголь­ни­ка. На ри­сун­ке ука­зан один из воз­мож­ных спо­со­бов рас­по­ло­же­ния стен и Ро­бо­та (Робот обо­зна­чен бук­вой «Р»).

Ответ на задание №14

пока спра­ва сво­бод­но

пока свер­ху сво­бод­но

нц пока слева сво­бод­но


Ответ на задание №15

пока спра­ва сво­бод­но

пока снизу сво­бод­но

пока не (снизу сво­бод­но)

пока не (спра­ва сво­бод­но)

пока не (свер­ху сво­бод­но)


Ответ на задание №16

пока не спра­ва сво­бод­но

пока не свер­ху сво­бод­но

пока свер­ху сво­бод­но

пока спра­ва сво­бод­но

пока не спра­ва сво­бод­но


У исполнителя Робот есть система команд. Рассмотрим простые команды Робота . Всего их 5:

вверх — переместить Робота на одну клетку вверх

вниз — переместить Робота на одну клетку вниз

влево — переместить Робота на одну клетку влево

вправо — переместить Робота на одну клетку вправо

Задание 1. Нарисовать квадрат со стороной 3 клетки.

Удаляем символ «|» и называем наш алгоритм «Квадрат» (рядом со служебным словом алг пишем Квадрат )

Запустить программу и посмотреть что получилось. Для запуска нажимаем F9 или же кнопку на панели инструментов Выполнить программу

Если такое окно Робота у вас не появилось, то на панели инструментов щелкните «Показать окно Робота » или в меню Робот выберите пункт «Показать окно Робота «. Продолжаем дальше:

Потом пойдем влево, закрашивая нижнюю границу квадрата

У нас осталась одна незакрашенная клетка. Закрасим ее

Все готово! В итоге наша программа выглядит так:

использовать Робот

алг Квадрат

Задание 2 .Используя простые команды Робота, написать программу, рисующую букву П, Р, Ш, Щ, Т,Н.

Цикл с условием.

У исполнителя Робот есть несколько условий: сверху свободно снизу свободно слева свободно справа свободно сверху стена снизу стена

слева стена справа стена

Нарисовать вертикальную линию от левой до правой границы поля использую цикл с условием. Изначально Робот находится в левом верхнем углу.

Исходный код нашей программы для Робота будет примерно такой:

использовать Робот

нц пока справа свободно

В результате выполнения этой программы мы увидим вот такую картину:

Задание 4 .Написать программу, которая будет делать рамку вокруг рабочего поля Робота независимо от его размера. Конечно же с использованием циклов с условием. В итоге должно получиться так:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *