Как настроить dhcp в cisco packet tracer
Перейти к содержимому

Как настроить dhcp в cisco packet tracer

  • автор:

DHCP сервер на маршрутизаторе cisco

Протокол DHCP – позволяет производить автоматическую настройку сети на компьютерах и других устройствах. DHCP может быть настроен на маршрутизаторах Cisco или на базе любого сервера. Данная статья описывает настройку DHCP сервера на маршрутизаторе Cisco. Однако, маршрутизатор может работать и как DHCP клиент – получая адрес на один из своих интерфейсов. Об этом можно прочесть подробнее здесь. Настройка DHCP сервера на маршрутизаторе это удобно в том плане, что если уже есть работающий маршрутизатор, то проще повесить на него максимальное количество функционала (интернет, NAT, DHCP и т.п.) чтобы каждое устройство занималось своим делом. DCHP позволяет автоматически настраивать на клиенте следующие основные параметры:

  1. IP адрес
  2. Основной шлюз
  3. Маска подсети
  4. DNS сервера
  5. Имя домена

Это наиболее частое использование DHCP, но можно передавать и огромное количество других параметров. Например, можно передавать дополнительные маршруты, чтобы в разные сети компьютер ходил через разные шлюзы. Или, с помощью DHCP можно организовывать загрузку устройств по сети. В этом случае клиент получает помимо основных параметров, адрес TFTP сервера и имя файла на нём (я имею в виду имя файла – загрузчика ОС, которую необходимо загрузить по сети).

Когда клиент, например, обычный компьютер, запускается, ОС видит, что для некой сетевой карты стоит «Получить параметры по DHCP». Такой компьютер не имеет пока IP адреса и происходит следующая процедура получения:

  1. Компьютер отправляет широковещательный запрос. При этом на втором уровне в фрейме стоит мак адрес отправителя – адрес компьютера, мак адрес получателя – ffff.ffff.ffff, а на третьем уровне – в пакете адрес отправителя отсутствует, адрес получателя стоит 255.255.255.255. Такое DHCP сообщение называется «DHCP discover».
  2. Далее все устройства в сети получают это широковещательное сообщение. DHCP сервера (а их теоретически может быть несколько) отвечают клиенту. Сервер резервирует в своём пуле адресов какой-то адрес (если не было резервации до этого для данного mac-адреса клиента) и выделяет этот ip клиенту на какое-то время (lease time). Берутся другие настройки и всё вместе высылается. При этом в качестве адресов получателя используется уже новый выделенный клиентский ip и клиентский mac. Это называется «DHCP offer».
  3. Клиент выбирает понравившийся ему сервер (обычно он всего один) либо выбирается тот кто ответил первым. И отправляет со своего mac и нового ip на mac и ip уже конкретного сервера «DHCP request» – согласие с полученными параметрами.
  4. Сервер резервирует за клиентом выделенный адрес на какое-то время (lease time). До этого момента адрес был выделен, но не зарезервирован. Теперь же он окончательно закреплён за клиентом. Сервер вносит так же строчку в свою ARP таблицу и высылает клиенту, сообщение, что он успешно зарегистрирован – «DCHP Acknowledge».
  5. Клиент начинает работать.

Давайте перейдём к настройке DHCP на маршрутизаторе. Есть одна странная, на первый взгляд вещь, на цисках DHCP как бы не привязан к конкретному интерфейсу, то есть просто создаётся пул и маршрутизатор раздаёт адреса где хочет. На самом деле, адреса раздаются не всем, а только на том интерфейсе, на котором Ip адрес из той же сети, что упоминается в пуле: действительно, какой смысл выдавать компьютеру адрес шлюза, который находится не в его сети.

DHCP сервер на cisco - топология

Настроим маршрутизатор, который будет выдавать по DHCP сеть 192.168.1.0/24 начиная с 192.168.1.11.

R1#configure terminal Enter configuration commands, one per line. End with CNTL/Z. R1(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10

Мы просим маршрутизатор не выдавать адреса с 192.168.1.1 по 192.168.1.10. Так как первый адрес будет использоваться самим маршрутизатором (шлюз), а остальные девять имеет смысл зарезервировать под различные сервера в этой сети. Серверам не стоит выдавать адреса по DHCP – к ним часто обращаются, поэтому адрес должен быть вбит статически и никогда не меняться. В нашем примере, например, присутствует DNS сервер с адресом 192.168.1.5, который вбит статикой. Теперь создаём пул:

R1(config)#ip dhcp pool MY-POOL R1(dhcp-config)#network 192.168.1.0 255.255.255.0 R1(dhcp-config)#default-router 192.168.1.1 R1(dhcp-config)#domain-name my-domain.com R1(dhcp-config)#dns-server 192.168.1.5 R1(dhcp-config)#exit

Выдаваться адреса будут из сети 192.168.1.0/24 (кроме тех что мы исключили ранее), в качестве шлюза будем выдавать 192.168.1.1 – наш маршрутизатор. Сам этот адрес надо ещё настроить:

R1(config)#interface fa0/0 R1(config-if)#ip address 192.168.1.1 255.255.255.0 R1(config-if)#no shutdown %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up R1(config-if)#exit R1(config)#exit R1# %SYS-5-CONFIG_I: Configured from console by console

После того, как компьютер получил адрес, можно проверить список выданных адресов:

R1#show ip dhcp binding IP address Client-ID/ Lease expiration Type Hardware address 192.168.1.11 000A.F337.2447 -- Automatic

К статье прилагаю пример данной конфигурации в Packet Tracer: DHCP сервер на cisco.

Настройка cisco dhcp в локальной сети

cisco dhcp

Настройка серверов windows и linux

Всем привет ранее мы закончили настраивать сеть для филиалов, и разобрались со статической маршрутизацией, но все это время настраивали компьютерам ip адреса в ручную. Для решения это задачи есть служба DHCP. Можно конечно использовать Windows DHCP, при наличии лицензии на Windows Server, но Cisco тоже умеет это делать на ура. Настроим давайте DHCP службу на Cisco, рассмотрим несколько вариантов.

Принцип работы DHCP

Как работает dhcp сервер, ответ на этот вопрос очень простой. Когда компьютер появляется в локальной сети, первым делом он отсылает в сеть широковещательный запрос, по всем кто в сети. Данный пакет называется DHCPDISCOVER, в котором он спрашивает ребята есть у вас тут DHCP, если да то дай как мне ip адрес. Если HDCP сервер в локальной сети есть, то он отвечает ему пакетом DHCPOFFER, в котором говорит вот я есть, вот тебе ip адрес, будешь брать? Компьютер получив пакет DHCPOFFER, отсылаем ему ответ в виде пакета DHCPREQUEST в котором говорит, отлично я беру это ip адрес запиши его за мной, на что DHCP получив этот пакет, отвечает пакетом DHCPACK в котором говорит что записал, что это ip адрес теперь твой. Вот весь принцип.

Принцип работы DHCP

В своей практике я встречал еще вот такие пакеты от dhcp сервера:

  • DHCPDECLINE — это пакет в котором клиент определил, что ip адрес, от DHCP сервера в момент предложения, уже используется кем то, и тогда будет сгенерирован новый запрос на другой ip адрес
  • DHCPRELEASE — данный пакет появляется когда клиент освобождает IP адрес
  • DHCPRENEW — Это пакет содержит в себе запрос на обновление и продление аренды ip адреса
  • DHCPINFORM — пакет, направленный клиентом к серверу DHCP, чтобы получить от него детальную информацию, пример, где находится запасной DHCP сервер в сети

Настройка dhcp cisco

Настройка для маленького офиса

У нас есть филиал, 3 компьютера, один коммутатор второго уровня Cisco 2960 и роутер Cisco 1841. Все компьютеры находятся в нативном vlan (vlan по умолчанию). Вот схема сети.

Настройка для маленького офиса

Приступаем к настройке Cisco 1841. Поднимем у него порт fa0/0 и назначим ему ip 192.168.1.1/24

enable
conf t
in fa0/0
no shutdown
ip address 192.168.1.1 255.255.255.0
exit

настройка cisco 1841

Видим, что порт загорелся зеленым.

поднять порт cisco 1841

Далее создаем pool ip адресов на cisco dhcp server, для этого вводим команду: DHCP_192.168.1.0 это имя

ip dhcp pool DHCP_192.168.1.0

Посмотрим теперь доступные команды

Router(dhcp-config)#?
default-router Default routers
dns-server Set name server
exit Exit from DHCP pool configuration mode
network Network number and mask
no Negate a command or set its defaults
option Raw DHCP options

cisco dhcp server

Задаем в начале сеть которую будем раздавать, естественно она должна быть в том же диапазоне что и ip адрес устройства Cisco. Создаю сеть 192.168.1.0

Настройка DHCP Cisco

Протокол DHCP позволяет производить автоматическую настройку сетевых устройств. Настройка DHCP сервера на маршрутизаторе выгодна тем, что позволяет по максимум задействовать работающий маршрутизатор, повесив на него максимальное количество функционала (интернет, NAT, DHCP и т.п.). DCHP позволит маршрутизатору автоматически настраивать на клиентах следующие основные параметры:

  • IP адрес
  • Основной шлюз
  • Маска подсети
  • DNS сервера
  • Имя домена

Ниже мы приводим для вас сразу несколько разных инструкций по настройке DHCP на оборудовании Cisco.

Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP

Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer

В этой видео инструкции рассматривается процесс настройки централизованного DHCP сервера в программе Cisco Packet Tracer.

  • как настроить пулы динамических IP адресов для различных сегментов локальной сети,
  • как настроить рабочую станцию на получение динамического IP адреса,
  • как проверить наличие получения динамического IP адреса рабочей станцией.

Новые команды для настройки маршрутизатора для получения пула динамических IP адресов у централизованного DHCP сервера.

Для примера рассматривается роутер R1

Настройки производятся в режиме глобальной конфигурации:

R1(config)#interface fastEthernet 0/1 — заходим в настройки интерфейса к которому подключен компьютер получающий динамический IP адрес

R1(config-if)#ip helper-address 192.168.30.11 указывается IP адрес централизованного DHCP сервера.

Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер, следующий:

R1(config)#interface Ethernet 0/1/0

R1(config-if)#ip address 172.33.56.1 255.255.255.0

R1(config)#ip dhcp excluded-address 172.33.56.1

R1(config)#ip dhcp excluded-address 172.33.56.254

R1(config)#ip dhcp pool R1SW6

R1(dhcp-config)#network 172.33.56.0 255.255.255.0

R1(config)#do sh ip prot

Routing Protocol is «bgp 1»

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

R1(config)#router bgp 1

R1(config-router)#do sh ip route

172.33.0.0/24 is subnetted, 1 subnets

C 172.33.56.0 is directly connected, Ethernet0/1/0

R1(config-router)#network 172.33.56.0 mask 255.255.255.0

Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети

Рассматривается настройка DHCP сервера на маршрутизаторе Cisco, показаны возможные причины неработоспособности сети, связанные с работой протоколов маршрутизации и варианты устранения данных неполадок.

Полезные команды настройке DHCP Cisco

  • Исключим из раздачи адрес 192.168.1.254 и адреса с 192.168.1.1 по 192.168.1.9

Router(config)# ip dhcp excluded-address 192.168.1.254

Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9

  • Настройка DHCP пула

Настройка DHCP сервера включает в себя определение пула адресов, которые будут раздаваться. Для создания пула используется команда ip dhcp pool [название_пула]. После этого необходимо ввести две обязательные команды – network [адрес_сети][маска/длина_префикса] для указания сети из которой будут раздаваться адреса и default-router[адрес_default_gateway] для указания шлюза по умолчанию (можно ввести до 8 адресов).

  • команда show ip dhcp binding показывает список всех IP адресов и сопоставленных с ними MAC адресов, которые были выданы DHCP сервером.
  • команда show ip dhcp server statistics покажет статистику DHCP сервера, включая информацию об отправленных и полученных DHCP сообщениях
  • Ретрансляция DHCP (DHCP RELAY)

Команда ip helper-address [адрес_DHCP-сервера] на маршрутизаторе в режиме конфигурации интерфейса укажет ему перенаправлять broadcast сообщения от DHCP клиентов уже в виде unicast к DHCP серверу, находящемуся в другой сети.

  • Настройка роутера DHCP клиента

Иногда роутер сам должен получить IP адрес по DHCP, например от интернет-провайдера. Для этого нужно в режиме конфигурации интерфейса ввести команду ip address dhcp, после чего интерфейс будет пытаться получить адрес от DHCP сервера.

Доставка по Москве, Санкт-Петербургу, в регионы России, в Казахстан, Беларусь

Оперативно подберем для Вас оборудование и аналоги

Настроим купленное у нас оборудование

Окажем профессиональную техподдержку

Гарантия 1 год (если не оговорено иное)

Артём Санников

Данная книга является руководством для начинающих специалистов в области анализа и обработки данных. В книге рассматривается язык SQL и его процедурное расширение PL/SQL от компании Oracle.

SQL без слёз

Цель книги заключается в том, чтобы научить любого человека работать с реляционными базами данных и получать из них необходимую информацию посредством выполнения SQL-запросов.

Главная › Cisco › Cisco Packet Tracer › Настройка DHCP пула. Cisco packet tracer.

Настройка DHCP пула. Cisco packet tracer.

Протокол DHCP (Dynamic Host Configuration Protocol) позволяет всем сетевым устройствам в автоматическом режиме получать IP-адреса и другие параметры необходимые для работы в сети. Протокол DHCP работает по модели Клиент-Сервер. Настроим серверную часть на коммутаторе в Cisco Packet Tracer.

Switch>en // Привилегированный режим EXEC
Switch#conf t // Режим глобальной конфигурации
Switch(config)#ip dhcp pool 404 // создаём новый пул с именем 404
Switch(dhcp-config)#network 172.23.2.0 255.255.255.0 // Указываем сеть, адреса которой будут присваиваться устройствам
Switch(dhcp-config)#default-router 172.23.2.1 // Указываем IP-адрес шлюза
Switch(dhcp-config)#dns-server 8.8.8.8 // Указываем IP-адрес dns сервера
Switch(dhcp-config)#lease 3 12 0 // Указываем срок аренды IP-адреса (дд-чч-мм) для устройства
Switch(dhcp-config)#domain-name test.ru // Указываем адрес домена
Switch(dhcp-config)#ex // Выходим из режима конфигурации dhcp пула
Switch(config)#ip dhcp excluded-address 172.23.2.10 // Указываем IP-адреса, которые нельзя присваивать в автоматическом режиме (в основном это статические адреса для факсов, принтеров и т.д)

Настройка пула DHCP. Cisco packet tracer.

Записи по теме

  • Запрет на передачу данных для MAC-адресов. Cisco packet tracer.
  • Запись MAC-адреса в рабочую конфигурацию. Cisco packet tracer.
  • Время старения MAC-адреса. Cisco packet tracer.
  • Количество MAC-адресов на порт устройства. Cisco packet tracer.
  • Активация функции port-security. Cisco packet tracer.
  • Исключение IP-адреса из пула DHCP. Cisco packet tracer.
  • Адрес домена для пула DHCP. Cisco packet tracer.
  • Срок аренды IP-адреса для пула DHCP. Cisco packet tracer.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *