Как найти повторяющиеся слова в excel
Перейти к содержимому

Как найти повторяющиеся слова в excel

  • автор:

Поиск и удаление повторений

В некоторых случаях повторяющиеся данные могут быть полезны, но иногда они усложняют понимание данных. Используйте условное форматирование для поиска и выделения повторяющихся данных. Это позволит вам просматривать повторения и удалять их по мере необходимости.

    Выберите ячейки, которые нужно проверить на наличие повторений.

Примечание: В Excel не поддерживается выделение повторяющихся значений в области «Значения» отчета сводной таблицы.

Удаление дубликатов 1

Выберите Главная >условное форматирование >выделение правил ячеек >повторяющихся значений.

Удаление дубликатов 2

В поле рядом со значениями выберите форматирование, которое нужно применить к повторяющимся значениям, а затем нажмите кнопку ОК.

Удаление повторяющихся значений

При использовании функции Удалить дубликаты повторяющиеся данные удаляются без возможности восстановления. Чтобы случайно не потерять необходимые сведения, перед удалением повторяющихся данных рекомендуется скопировать исходные данные на другой лист.

    Выделите диапазон ячеек с повторяющимися значениями, который нужно удалить.

Совет: Перед попыткой удаления повторений удалите все структуры и промежуточные итоги из своих данных.

Удаление дубликатов 3

Выберите Данные >Удалить дубликаты, а затем в разделе Столбцы проверка или снимите флажок столбцов, в которых нужно удалить дубликаты.

Выделенные повторяющиеся значения

Например, на данном листе в столбце «Январь» содержатся сведения о ценах, которые нужно сохранить.

Удаление дубликатов 5

Поэтому флажок Январь в поле Удаление дубликатов нужно снять.

Примечание: Количество повторяющихся и уникальных значений, заданных после удаления, может включать пустые ячейки, пробелы и т. д.

MS Excel

В Excel можно не только выделять и удалять дублирующие данные, но и работать с ними – посчитать дубли перед удалением, обозначить дубли словами, числами, знаками, найти повторяющиеся строки, состоящие из нескольких ячеек, т.д.

Дублирующие данные подкрасили условным форматированием.
Есть два варианта выделять ячейки с одинаковыми данными. Первый вариант, когда выделяются все ячейки с одинаковыми данными. Второй вариант – выделяем вторую и следующие ячейки в одинаковыми данными .

Первый способ.
Как выделить повторяющиеся значения в Excel .
Нам нужно в соседнем столбце напротив данных ячеек написать слово «Да», если есть дубль, у ячеек с уникальными данными написать слово «Нет».
В столбце А устанавливаем фильтр. В ячейке B2 пишем слово «Нет».

Слово скопируется вниз по столбцу до последней заполненной ячейки таблицы.
Теперь в столбце A отфильтруем данные – «Фильтр по цвету ячейки». Можно по цвету шрифта, зависит от того, как выделены дубли в таблице.

В таблице остались две строки с дублями. В верхней ячейке отфильтрованного столбца B пишем слово «Да». Копируем по столбцу.

Возвращаем фильтром все строки в таблице.

Мы подсветили ячейки со словом «Да» условным форматированием .
Этот способ подходит, если данные в столбце A не меняются.

Второй способ.
Как выделить повторяющиеся ячейки в Excel .
Установим формулу в столбце D, чтобы автоматически писались слова. =ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1;»Да»;»Нет»)
Копируем формулу по столбцу.

Т акое выделение дублей, выделяет словом «Да» следующие повторы в ячейках, кроме первой ячейки.

Слова в этой формуле можно писать любые или числа, знаки. =ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1;»Повторно»;»Впервые»)
В столбце F написали формулу. =ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1 ;»+»;»-«)

Можно в таблице использовать формулу из столбца E или F, чтобы при заполнении соседнего столбца было сразу видно, есть дубли в столбце или нет . =ЕСЛИ(СЧЁТЕСЛИ(A$5:A5;A5)>1;»+»;»-«) Если в столбце В стоит «+», значит такую фамилию уже написали .

Третий способ.
Посчитать количество одинаковых значений Excel .
Нам нужно не только выделить повторы, но и вести их подсчет, написать в ячейке их количество.
В ячейке G5 пишем такую формулу. =ЕСЛИ(СЧЁТЕСЛИ(A$5:A$10;A5)>1;СЧЁТЕСЛИ(A$5:A5;A5);1) Копируем по столбцу .

Изменим данные в столбце А для проверки.

Четвертый способ.
Формула для поиска одинаковых значений в Excel .
Нам нужно выделить дубли формулой в условном форматировании. Выделяем ячейки. Вызываем диалоговое окно условного форматирования. Выбираем функцию «Использовать формулу для определения форматируемых ячеек».
В строке «Форматировать формулу для определения форматируемых ячеек» пишем такую формулу. =СЧЁТЕСЛИ($A:$A;A5)>1 Устанавливаем формат, если нужно выбрать другой цвет ячеек или шрифта.

Нажимаем «ОК». Все ячейки с повторяющимися данными окрасились.
Можно в условном форматировании установить белый цвет заливки и шрифта.

Первые ячейки остались видны, а последующие повторы не видны. При изменении данных в первом столбце меняются и пустые ячейки, в зависимости от того, где находятся дубли.
Пятый способ.
Нужно сравнить и выделить данные по трем столбцам сразу.

В столбцах A, B, C стоят фамилии, имена и отчества. Чтобы сравнить сразу по трем столбцам, нужно соединить данные трех столбцов в одной ячейке. В ячейке D15 пишем формулу, используя функцию «СЦЕПИТЬ» в Excel . =СЦЕПИТЬ(A15;» «;B15;» «;C15)

Как найти одинаковые значения в столбце Excel

Поиск дублей в Excel – это одна из самых распространенных задач для любого офисного сотрудника. Для ее решения существует несколько разных способов. Но как быстро как найти дубликаты в Excel и выделить их цветом? Для ответа на этот часто задаваемый вопрос рассмотрим конкретный пример.

Как найти повторяющиеся значения в Excel?

Допустим мы занимаемся регистрацией заказов, поступающих на фирму через факс и e-mail. Может сложиться такая ситуация, что один и тот же заказ поступил двумя каналами входящей информации. Если зарегистрировать дважды один и тот же заказ, могут возникнуть определенные проблемы для фирмы. Ниже рассмотрим решение средствами условного форматирования.

Список закзов.

Чтобы избежать дублированных заказов, можно использовать условное форматирование, которое поможет быстро найти одинаковые значения в столбце Excel.

Пример дневного журнала заказов на товары:

Чтобы проверить содержит ли журнал заказов возможные дубликаты, будем анализировать по наименованиям клиентов – столбец B:

  1. Выделите диапазон B2:B9 и выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило». Создать правило.
  2. Вберете «Использовать формулу для определения форматируемых ячеек». Формула.
  3. Чтобы найти повторяющиеся значения в столбце Excel, в поле ввода введите формулу: =СЧЁТЕСЛИ($B$2:$B$9; B2)>1. Зеленый.
  4. Нажмите на кнопку «Формат» и выберите желаемую заливку ячеек, чтобы выделить дубликаты цветом. Например, зеленый. И нажмите ОК на всех открытых окнах.

Дубликаты.

Как видно на рисунке с условным форматированием нам удалось легко и быстро реализовать поиск дубликатов в Excel и обнаружить повторяющиеся данные ячеек для таблицы журнала заказов.

Пример функции СЧЁТЕСЛИ и выделение повторяющихся значений

Принцип действия формулы для поиска дубликатов условным форматированием – прост. Формула содержит функцию =СЧЁТЕСЛИ(). Эту функцию так же можно использовать при поиске одинаковых значений в диапазоне ячеек. В функции первым аргументом указан просматриваемый диапазон данных. Во втором аргументе мы указываем что мы ищем. Первый аргумент у нас имеет абсолютные ссылки, так как он должен быть неизменным. А второй аргумент наоборот, должен меняться на адрес каждой ячейки просматриваемого диапазона, потому имеет относительную ссылку.

Самые быстрые и простые способы: найти дубликаты в ячейках.

После функции идет оператор сравнения количества найденных значений в диапазоне с числом 1. То есть если больше чем одно значение, значит формула возвращает значение ИСТЕНА и к текущей ячейке применяется условное форматирование.

  • Создать таблицу
  • Форматирование
  • Функции Excel
  • Формулы и диапазоны
  • Фильтр и сортировка
  • Диаграммы и графики
  • Сводные таблицы
  • Печать документов
  • Базы данных и XML
  • Возможности Excel
  • Настройки параметры
  • Уроки Excel
  • Макросы VBA
  • Скачать примеры

Как найти одинаковые строки в Excel и выделить их цветом

Достаточно часто рабочие таблицы Excel содержат повторяющиеся записи, которые многократно дублируются. Но не всегда повторение свидетельствует об ошибке ввода данных. Иногда несколько раз повторяющиеся записи с одинаковыми значениями были сделаны намеренно. Тогда проблема может возникнуть при обработке, поиске данных или анализе в такой таблице. Чтобы облегчить себе работу с такими таблицами, рекомендуем автоматически объединить одинаковые строки в таблице Excel, выделив их цветом.

Как объединить одинаковые строки одним цветом?

Чтобы найти объединить и выделить одинаковые строки в Excel следует выполнить несколько шагов простых действий:

  1. Выделите весь диапазон данных табличной части A2:F18. Начинайте выделять значения из ячейки A2, так чтобы после выделения она оставалась активной как показано ниже на рисунке. И выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило». Создать правило1.
  2. В появившемся окне «Создание правила форматирования» выберите опцию: «Использовать формулу для определения форматированных ячеек». СЦЕПИТЬ.
  3. В поле ввода введите формулу: 1′ >Зеленая заливка.
  4. Нажмите на кнопку формат, чтобы задать цвет заливки для ячеек, например – зеленый. И нажмите на всех открытых окнах кнопку ОК.

Одинаковые строки.

В результате выделились все строки, которые повторяются в таблице хотя-бы 1 раз.

Как выбрать строки по условию?

Форматирование для строки будет применено только в том случаи если формула возвращает значения ИСТИНА. Принцип действия формулы следующий:

Первая функция =СЦЕПИТЬ() складывает в один ряд все символы из только одной строки таблицы. При определении условия форматирования все ссылки указываем на первую строку таблицы.

Абсолютные и относительные адреса ссылок в аргументах функций позволяют нам распространять формулу на все строки таблицы.

Вторая функция =СЦЕПИТЬ() по очереди сложить значение ячеек со всех выделенных строк.

Обе выше описанные функции работают внутри функции =ЕСЛИ() где их результаты сравниваются между собой. Это значит, что в каждой ячейке выделенного диапазона наступает сравнение значений в текущей строке со значениями всех строк таблицы.

Как только при сравнении совпадают одинаковые значения (находятся две и более одинаковых строк) это приводит к суммированию с помощью функции =СУММ() числа 1 указанного во втором аргументе функции =ЕСЛИ(). Функция СУММ позволяет сложить одинаковые строки в Excel.

Если строка встречается в таблице только один раз, то функция =СУММ() вернет значение 1, а целая формула возвращает – ЛОЖЬ (ведь 1 не является больше чем 1).

Если строка встречается в таблице 2 и более раза формула будет возвращать значение ИСТИНА и для проверяемой строки присвоится новый формат, указанный пользователем в параметрах правила (заливка ячеек зеленым цветом).

Как найти и выделить дни недели в датах?

Допустим таблица содержит транзакции с датами их проведения. Необходимо найти одну из них, но неизвестны все детали. Известно только, что транзакция проведена во вторник или в среду. Чтобы облегчить себе поиск, выделим цветом все даты этих дней недели (вторник, среда). Для этого будем использовать условное форматирование.

  1. Выделите диапазон данных в таблице A2:B11 и выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило». Создать правило2.
  2. В появившемся окне «Создание правила форматирования» выберите опцию: «Использовать формулу для определения форматированных ячеек». Использовать формулу.
  3. В поле ввода введите формулу: Зеленый фон.
  4. Нажмите на кнопку формат, чтобы задать цвет заливки для ячеек, например – зеленый. И нажмите на всех открытых окнах кнопку ОК.

Дни недели.

Все транзакции, проводимые во вторник или в среду выделены цветом.

  • Создать таблицу
  • Форматирование
  • Функции Excel
  • Формулы и диапазоны
  • Фильтр и сортировка
  • Диаграммы и графики
  • Сводные таблицы
  • Печать документов
  • Базы данных и XML
  • Возможности Excel
  • Настройки параметры
  • Уроки Excel
  • Макросы VBA
  • Скачать примеры

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *